Chapter 3. System Requirements

The following requirements must be fulfilled in order for CloverDX to run:

Hardware

Software

The support for 32-bit Linux was removed in 4.5.0.

Firewall

[Important]Important

JDK is needed for compilation of Java transformations and for compilation of CTL2 to Java.

Installation

Software requirements:

  • Microsoft Windows, Mac OS X - none, the installer includes Eclipse Platform 4.7 for Java developers with RSE + GEF + Eclipse Web Tools Platform.

  • Linux - Java 8 or 9 Runtime Environment (Java 8 Development Kit is recommended). We recommend libwebkitgtk-1 library