Chapter 6. System Requirements

Hardware Requirements

The following table shows hardware requirements for both Basic and Corporate CloverDX Server edition and for running CloverDX Server in a cluster.

Table 6.1. Hardware requirements of CloverDX Server

 Basic EditionCorporate EditionCluster
RAM4 GB (recommended 16 GB)8 GB (recommended 64 GB)8 GB (recommended 64 GB)
Processorsup to 4 cores16 cores8 cores [a]
Disk space (installation)1 GB1 GB1 GB
Disk space (tempspace)> 25 GB [b] > 25 GB [b]> 25 GB [b]
Disk space (data)> 50 GB [b]> 50 GB [b]> 50 GB [b]
Disk space (shared) [c] --> 50 GB [b]

[a] This may vary depending on total number of nodes and cores in license.

[b] Minimum value, the disk space depends on data.

[c] Disk space for shared sandboxes is required only for CloverDX Cluster.


Software Requirements

Operating system

CloverDX Server is compatible with Windows and Unix-based systems, as well as with other systems supporting Java (Mac OS X, IBM System, etc.).

Java Virtual Machine
  • Oracle JDK 8 or 9 64 bit

  • IBM SDK 8 (for IBM WebSphere only)

Since it is a Java application, it requires Java Development Kit (JDK) to run. We do not recommend using Java Runtime Environment (JRE) only, since compilation of some CloverDX Server's transformations requires JDK to function properly.

Application Servers Compatible with CloverDX 5.0

Table 6.2. Compatibility Matrix

 CloverETL 4.1 to 4.7CloverETL 4.8 to 4.9CloverDX 5.0 and newer
Application ServerJava 7Java 8Java 7Java 8Java 8Java 9
Tomcat 6
yes
yes
no
no
no
no
Tomcat 7
yes
yes
yes
yes
no
no
Tomcat 8
yes
yes
yes
yes
no
no
Tomcat 8.5
no
no
yes[a]yes[a]
yes
yes
Tomcat 9
no
no
no
yes
yes
yes
Pivotal tc Server Standard (3.1.9, Tomcat 8)
no
yes
no
yes
no
no
Pivotal tc Server Standard (3.2.9, Tomcat 8.5)
no
no
no
yes[a]
yes
yes
Jetty 9
yes
yes
yes
yes
no
no
WebLogic Server 11gR1 (10.3.6)
yes
no
4.8 yes / 4.9 no
no
no
no
WebLogic Server 12cR1 (12.1.2)
yes
no
yes
no
no
no
WebLogic Server 12cR1 (12.1.3)
yes
yes
yes
yes
no
no
WebLogic Server 12cR2 (12.2.1)
no
no
no
no
yes
no
JBoss AS 6
yes
no
yes
no
no
no
JBoss AS 7yes[b]yes[c]yes[b]yes[c]
no
no
JBoss EAP 7
no
no
no
no
yes
no
Glassfish 3
yes
no
yes
no
no
no
WebSphere 8.5
yes
no
yes
no
no
no
WebSphere 9
no
no
no
no
yes
no

[a] Since 4.8.2

[b] EAP 6.2

[c] EAP 6.4


[Note]Note

We support Java 8 and 9 on particular supported application server only if the application server itself officially supports it.

Database servers

We support the following database servers. The officially supported versions, we are testing against, are in parentheses.

The evaluation version uses an embedded Apache Derby database for evaluation purposes. We do not support using the Derby database in production environment. Instead you can choose one of several supported database servers.